Asus Z97-Pro (WiFi ac) bios update fail

Discussion in 'Processors, Motherboards & Memory' started by trodas, Dec 21, 2015.

  1. trodas

    trodas Newbie

    My Asus Z97-Pro (WiFi ac) have bios v2303:


    So I load the new bios (all the more recent bioses anyway) on USA flash:


    I picked up the latest one (v2702) and tried...

    [​IMG] upload it, then I get "not a proper BIOS" message:


    NONE of the bioses I tested (v2401, v2501, v2601 and v2702) worked. All I download directly from Asus site:
    Z97-PRO(Wi-Fi ac) - Podpora could SOMEBODY tell me, what is going on?!

    Next thing - let's try the mainboard function of USB BIOS Flashback - I put into the proper port (page 2-14 "bottom port supports USB BIOS Flashback") USB drive with file in the root directory, renamed by the BRenamerl.exe utility to "Z97P.CAP")

    After power up, I hold the BIOS_FLBK button for 3+ seconds and I expected to see 3 blinks of the LED and beggining of the flash proces, but ABSOLUTELY NOTHING HAPPEND.

    The last attempt to flash bios update on Asus Z97-Pro (WiFi ac) was my attempt to boot from USB flash. Formated as DOS bootable device (or DrDOS) and in both attempts failed. Even afer disconnecting both SATA devices (HDD + DVD).

    So the mainboard works, but it did not see the Samsung SM951 (MZ - HPV1280) M.2 128G SSD is not seen as device in bios or HDD prep programs like Mini Tool Partition Wizard Pro. Any help is need:


    ...perhaps it is just me, doing something wrong?
  2. Chai

    Chai Administrator Staff Member

    I have a feeling that the bios available on the website is not the correct bios for your board even though it stated so. If you noticed, there's no 2303 version on the website.

    Sent from my Nexus 7 using Tapatalk
    Last edited: Dec 23, 2015
  3. zy

    zy Staff Member

    Adrian Wong likes this.
  4. trodas

    trodas Newbie

    Oh, f****

    Ooops, my epic fail, lol... Yes, it is the wrong board.

    Now I finally have the bios updated! I completely forget, that my mainboard is not "Asus Z97-PRO (WiFi ac)", but a "Asus Z97-PRO (WiFi ac)/USB 3.1" and that means, that I tried different BIOSes. Witch end up with the "impossibility to update" the bios.

    Now I running at bios v2702, yet the M.2 SSD (Samsung SM951) is still "not present" in bios, or for HDD prep program (Mini Tool Partition Wizard Professional) or visible for Windows 7 install:
    Asus Z97-Pro (WiFi ac) not see my M.2 SSD drive
  5. Chai

    Chai Administrator Staff Member

    Is there any firmware upgrade for your ssd?

    Sent from my Nexus 7 using Tapatalk
  6. zy

    zy Staff Member

    Was it working before that or you have just added it in?

    I've never done a M.2 setup before, but I did some reading online and it seems that you have to be doing an UEFI installation rather than traditional BIOS setup. SATA AHCI instead of IDE mode.

    Are you using a DVD or USB as installation source for your Windows 7?
  7. trodas

    trodas Newbie

    Dunno, if there is some firmware update for my SSD, as the SSD is not accesible/visible in the only one computer with M.2 slot I have, I can't do it ayway. And no, it was never tried anywhere - there is simply no place where to try the device...

    AHCI mode for SATA used.

    I wanted to install the Win7 on the M.5 Samsung 951 and I failed :( I tried this:

    As this method looks very promising, however it fail to work on Asus Z97-Pro (WiFi ac)/usb 3.1 - with Samsung SM951 M.2 SSD. Rufus easily create the USB boot install Win7 Pro drive, no problemo there. However when I use the recommended bios setup, it ALWAYS reset the computer right after the "Starting Windows" message on screen appears. After that, the Asus board tell me, that it adjusted my bios settings to make the problem "go away" (it re-enable the CSM!) and then the install works, however it did not see single drive :( (all except M.2 are unpluged)

    Latest bios are now used. Asked Asus support and get funny message, that basically says, that Asus only support following M.2 SSD drives it list there: Z97-PRO-WiFi-AC-USB31_Devices_Report.pdf
    And the best part of the message is: "Asus do not guarantee functionality of this manboard with other that listed M.2 SSD drives." WTF ...

    Any help will be greatly appreciated.

    I tried different bios settings regarding the CSM, but the rule seems to be that disabled CSM lead to reboot :(

    The guide is basically about that for the first part of Win install on M.2 SSD drive, you need to:
    - completely disable CSM (Boot/CSM)
    - select Secure Boot to "Other OS"
    - select Key Management to "Clear Secure Bootkeys"

    ...install Win thru first reboot, then...

    Secure Boot: Windows UEFI Mode (instead of completely disabling CSM)
    Key Management: Install Default Secure Boot Keys

    So it was sound reasonable, however it failed completely :(
  8. zy

    zy Staff Member

    When you created using Rufus, did you select:

    • GPT partition scheme for UEFI
    • FAT32

    And are you using the USB 2.0 ports to install?
  9. Adrian Wong

    Adrian Wong Da Boss Staff Member

    It could be a Windows 7 driver SATA AHCI limitation because at that time, M.2 did not exist. Try installing Windows 8 or Windows 10 instead, even if it's just as a test. If you can install either Windows 8 / 10, then you can be sure it's really just Windows 7's default SATA AHCI driver at fault.

Share This Page