How To Fix The PCI Express x1 Bug

Discussion in 'Reviews & Articles' started by Dashken, Mar 21, 2008.

  1. Dashken

    Dashken Administrator!

    How To Fix The PCI Express x1 Bug Rev. 3.0

    User of ASUS and Gigabyte motherboards (maybe others as well) may be affected by a PCI Express x1 bug which causes a tremendous drop in performance. ChampionLLY takes a look at the motherboards and graphics cards affected by this problem and what solutions work, and what doesn’t.

    In the second part, he takes a look at the effect that PCI Express x1 bug has on the performance of your system. The results will shock you.

    Here are the latest updates in Revision 3.0 :-

    Link : How To Fix The PCI Express x1 Bug Rev. 3.0
  2. vaan009

    vaan009 Newbie

    I haved mainboard Gigabyte 965P-S3 Rev 3.3,VGA Sapphire HD4850 and I am still seeing the x1 bug.How can you fix the PCI Express x1 bug of this mainboard?

    Thank you,
  3. Hi Dasken,

    There is a mistake with your guide

    There is no Asus P35C-DS3R. Only Gigabyte uses the Pxx-DSx naming scheme. Here's the link:

    GIGABYTE - Product - Motherboard - Overview - GA-P35C-DS3R (rev. 2.1)

    Hope you fix it:thumb:
  4. Adrian Wong

    Adrian Wong Da Boss Staff Member

  5. Adrian Wong

    Adrian Wong Da Boss Staff Member

    Have you gone through the various fixes we mentioned?
  6. weezy

    weezy Newbie

    I have, this problem is insane, tried everything imaginable and i know its the motherboard not setting things correctly.
  7. Adrian Wong

    Adrian Wong Da Boss Staff Member

    Hmm.. Have you contacted Gigabyte about this?? :think:
  8. RobA

    RobA Newbie

    Hey there, I have had this problem for a little while but decided to have one last look on the internet and found this discussion.

    I have got a Asus P5K-E WiFi/AP, BFG 8800 GTS 512, Crucial Ballistix Tracer, I have tried setting the NB voltage to 1,40 V as that is the only thing lower that 1.45. I have also tried setting the PCI-E regerence clock to 115 but still no luck. I have tried disabling the PEG Force X1, and it is still as x1.

    Hopefully someone can help.

    Also I have not overclocked the PC.

    Would I be able to send it back to where I bought it from or would they tell me that its something that I can't send it back for?
    Last edited: Dec 9, 2008
  9. Adrian Wong

    Adrian Wong Da Boss Staff Member

    IMHO, if you can show them that the board's stuck at PCI Express x1, they should replace it with a different motherboard. Running any graphics card at PCIe x1 is ridiculous. :mad:

    I know you tried reducing the NB voltage, but have you tried increasing it above 1.5V?
  10. PsYkHoTiK

    PsYkHoTiK Admin nerd

    @Roba: I run a P5K Premium with a eVGA G92 8800GTS 512 and I don't have the problem.

    Man I was just about to go ZOMG don't tell me this is strike three from my Asus mobo!

    Good thing my GPU is happily running @ 16x. :o

    Attached Files:

  11. Adrian Wong

    Adrian Wong Da Boss Staff Member

    That reminds me, RobA. Did you update the motherboard BIOS?
  12. Chai

    Chai Administrator Staff Member

    Have you tried updating the BIOS?

    Edit: LOL, 20mins too slow...
  13. RobA

    RobA Newbie

    Thanks for the replys, I don't really know how to update the BIOS, I've read about doing it but am still not sure, if anyone could give me a step by step guide I would be very grateful.
  14. Adrian Wong

    Adrian Wong Da Boss Staff Member

    Fortunately for you, we have a guide on this subject - Tech ARP - Motherboard BIOS Flashing Guide
  15. RobA

    RobA Newbie

    I like to think that I'm quite good with computers, having built my own and reinstalled systems many a time. I read all of that guide and up until the "Flashing the motherboard BIOS" bit I was understanding it completly,
    I have noticed that on my start menu I have got a program called ASUSUpdate. Can I use that instead of doing all of that floppy drive stuff.
    Last edited: Dec 14, 2008
  16. Adrian Wong

    Adrian Wong Da Boss Staff Member

    Oh yes, you can! Just download the BIOS file to a hard disk drive or flash drive, then use ASUSUpdate to load the new BIOS image.
  17. RobA

    RobA Newbie


    I've updated it to the latest one, tried all of the things in the guide and still no joy, I'll have to ring up the people I got it from and speak to them and maybe have to send it back. This is ridiculous!

    Edit: I've just updated the forceware on the graphics to the 180, and still no joy.
    Last edited: Dec 14, 2008
  18. Adrian Wong

    Adrian Wong Da Boss Staff Member

    It's a hardware problem alright. Those are just possible workarounds for the issue. Sorry to see they didn't work for you. The best solution would be to have the motherboard replaced.
  19. RobA

    RobA Newbie

    Thanks for all of the help guys, I'm not so sure whether to get another ASUS board or not now. If I can't get a direct swap, what other boards are there from ASUS and other maunfacturers that are on par with my board?
  20. Marcel.

    Marcel. Newbie

    This problem also seems to occur with the Asus P5kPL.
    None of the remedy methods can be carried out on this motherboard as none of the options are available.

    The p5kpl is PCI-e 1.0 and I'm running it with a 2.0 Card (GTX 260)

    I'm wondering if anyone knows any other possible ways to fix this problem?

Share This Page