How To Fix The PCI Express x1 Bug

Discussion in 'Reviews & Articles' started by Dashken, Mar 21, 2008.

  1. Adrian Wong

    Adrian Wong Da Boss Staff Member

    How about the ASUS P5Q series of motherboards? They seem pretty good. :thumb:
  2. Adrian Wong

    Adrian Wong Da Boss Staff Member

    Wait.. Please don't confuse PCI Express 1.0 with PCI Express x1. They are two different things.

    Both PCI Express 1.0 and 2.0 support x16 lanes. The problem we are discussing pertains to a graphics card that supports PCI Express x16 getting stuck at running with only 1 lane.
  3. g0tanks

    g0tanks Newbie

    Yeah the P5Q series should do fine, take a look at the P5Q Pro or P5Q-E.
  4. waca

    waca Newbie

    I have a ga-ep35c-ds3r with the infamous bug. I have tried the options in guide without success ( I cant change pci-e frequency, I tried to change NB without results, etc) I saw in other forums that a guy fixed the bug installing the video card in another motherboard and after in the original motherboard, and magically it worked, its the only thing that I know that I did not tried, because I dont have another board.
    Any other options?
    Last edited: Mar 24, 2009
  5. Adrian Wong

    Adrian Wong Da Boss Staff Member

    Sorry, no. If we know of a better solution, you can be sure we will update the guide. If you know of any other solutions, please let us know.

    Have you tried updating the BIOS though?
  6. waca

    waca Newbie

    yes, last version (f4beta) and no results
  7. JackHandy

    JackHandy Newbie

    Think this issue is happening to me too - Here's my GPU-Z and CPU-Z screenshots (nevermind, don't have ability to post images in forum yet.)

    Using an Nvidia GeForce 9500GS, Bus Interface in GPU-Z says PCI-E x 16 @ x1.

    CPU-Z has the following info:

    Manufacturer - Pegatron Corporation
    Model - Benicia 1.01
    Chipset - Intel P35/G33/G31 Rev. A2
    Southbridge - Intel 82801IR(ICH9R)
    LPCIO Fintek F800

    Brand - American Megatrends Inc.
    Version - 5.32
    Date 10/21/2008

    Graphic Interface
    Version PCI-EXPRESS
    Link Width x1 Max Supported x16

    Unfortunately, none of the settings that are suggested in the article are available in my BIOS (ok, I'm a noob, maybe it's something obvious that I'm missing). Or is it something HP related, that's restricting me from these options?
  8. Adrian Wong

    Adrian Wong Da Boss Staff Member

    Yes, looks like you are affected.

    If you have already tried all the steps, including updating the BIOS, then the only recourse is to send it back to the motherboard company and have them replace it. :(
  9. RobA

    RobA Newbie

    Hey guys and gals, I posed about my problems with the PCI-E running at X1, late last year and I have now sorted it.

    I tried my cousins ATI 4870 in my computer and it ran fine, I tried my BFG 8800 GTS in his computer and it ran at X1, I then sent it back to where I bought it from.

    WOOP! I'm glad its sorted!

    Thanks for all the help and advice from everyone. :thumb:
  10. Adrian Wong

    Adrian Wong Da Boss Staff Member

    No problem! Glad it worked out for you! :thumb:
  11. carambazi

    carambazi Newbie

    Hi !

    At last, I've managed to correct that nasty sounds stattering bug I had with my Asus P5Bdeluxe motherboard and get a PCI 16x @ 16 link.
    Since I've had my new 9800 gt, I've only had sound issues. Thanks a bunch to TechArp for the article and to this post on the nvdia forum :

    Here are the settings
    - PCI Synchronization Mode to Auto ( that was the crucial thing do to for me, unless I hadn't changed that, no 16x@16 link )
    - Setting the PCIE Bus Frequency to 115 Mhz
    - Set the NB Vcore to 1.45
    - Disable "PEG Force X1
    - Set the peg link to Normal ( used to be Auto )

    And now, the sounds stutters are GONE !!!! and no more DPC latency issues. I'm so thankful to you guys for posting your replies, they were really helpful and it ended this nightmare !

    PS: my rev bios is 1226, using intel dual core 6400, sp2, and a external Firewire Solo as sound card.
  12. Adrian Wong

    Adrian Wong Da Boss Staff Member

    That's great news, carambazi! :thumb:
  13. peterf

    peterf Newbie

    I have the same motherboard but I can not get it to go into x16!
    I have an E6600 with an 8800GTS 512MB.
    It will only go up to x2 no matter what I try! I have put the same BIOS that you are using and have the same problem.

    Stupid ASUS takes about a month with RMAs, too! :wall: :wall: :wall:
  14. Adrian Wong

    Adrian Wong Da Boss Staff Member

    Did you try the steps he outlined?
  15. peterf

    peterf Newbie

    Yes! I will have to RMA if I want it to work.
  16. Adrian Wong

    Adrian Wong Da Boss Staff Member

    How To Fix The PCI Express x1 Bug Rev. 3.1

    User of ASUS and Gigabyte motherboards (maybe others as well) may be affected by a PCI Express x1 bug which causes a tremendous drop in performance. ChampionLLY takes a look at the motherboards and graphics cards affected by this problem and what solutions work, and what doesn’t.

    In the second part, he takes a look at the effect that PCI Express x1 bug has on the performance of your system. The results will shock you.

    Here are the latest updates in Revision 3.1 :-

    Link : How To Fix The PCI Express x1 Bug Rev. 3.1
  17. Melchian

    Melchian Newbie

    Hi guys, im new here, im having the same problem, i read all the post and i do everything but cant solve it.
    My board is GA-EP43-UD3L, i cant find the option to decrease NB CORE voltage, i tried increasing the PCI-E frequency but cant go more than 106mhz.
    My video card is XFX GF9600GT 512 DDR3.
    I hope someone can help :pray:
    Thanks for ur time guys :thumb:
  18. Adrian Wong

    Adrian Wong Da Boss Staff Member

    Hi Melchian,

    The BIOS options available to you depends on the motherboard manufacturer. Some motherboards may not come with the BIOS options we listed.

    However, you can try updating the BIOS of your motherboard. That may :
    a) fix the problem
    b) provide you access to previously unavailable BIOS options
  19. x1 bug

    Im having the same problem as Melchian, my mother board is a GA-EP45-UD3P Rev.1.0 with bios version F9. i updated my bios but i still do not have any of the options for fixing this problem. my card is a 9800 gtx. Ive made sure all my drivers are up to date, i have made sure the pci-e slot was clean and i made sure the card was properly installed. Still at a loss here.
  20. Adrian Wong

    Adrian Wong Da Boss Staff Member

    The trouble is if the motherboard BIOS does not offer you the option of changing the NB Core voltage, there's really nothing you can do about it. :(

    I would suggest you try to get the dealer to exchange it with a different motherboard.

    We are hoping that other people affected by this problem would be able to find further solutions. If there are any new solutions, we will update the article. Unfortunately, at this point in time, these are the possible solutions that we know of. :(

Share This Page