How To Fix The PCI Express x1 Bug

Discussion in 'Reviews & Articles' started by Dashken, Mar 21, 2008.

  1. zy

    zy Staff Member

    The Gigabyte listed should have MCH Core which I believe is NB Core?
  2. Adrian Wong

    Adrian Wong Da Boss Staff Member

    Oh, there's MCH Core? Then yes, it's the same thing.
  3. this is what i have under my options
    Mother Board Voltage
    Load-line calibration......disabled
    CPU VCore 1.25000v........(auto)
    CPU termination 1.2......(auto)
    CPU reference 0.760v....(auto)
    MCH Core 1.100v.....(auto)
    MCH reference 0.900v....(auto)
    MCH I/O 1.5....(auto)
    ICH Core 1.1000v....(auto)
    >>> Dram

    also this is what i have for the rest of the options
    Robust Graphic Booster (auto)
    CPU Clock Ratio (8x)
    Fine CPU Clock ratio (+0.0)
    PCI express frequency(Mhz) (auto)

    if i could figure out how to print the screen i would =( sorry not very computer savy

    I see that MCH is the same thing but what about
    # New! Set PCI Synchronization Mode to Auto. This is an important step.
    # New! Set PEG Link Mode to Normal (instead of Auto).
    are these under something else that would be the same?
    Last edited: Jan 29, 2010
  4. Adrian Wong

    Adrian Wong Da Boss Staff Member

    You don't have to print screen. If you have a digital camera handy, you can take photos of the BIOS screens and post them here.

    The MCH Core is what you are looking for. PEG refers to PCI Express. Here's the lowdown on PEG Link Mode - Tech ARP - PEG Link Mode

    You can try adjusting the PCI Express Frequency and see if that helps.
  5. K12

    K12 Newbie

    Hi there,

    I am having the same problem but with my ASUS P5KR and HIS HD 2600XT. Tried some of the stuff here and now its showing it as 'x2' and not 'x1' anymore. Anything else I can do?

    ASUS P5KR (Bios v.0703)
    HIS HD 2600XT
    Corsair Value Select 2GB(2x1) RAM

    I will be happy to provide any other details required.
    Thanks for your time.
  6. Adrian Wong

    Adrian Wong Da Boss Staff Member

    Why don't you post the graphics-related BIOS settings you have enabled/disabled on your motherboard?
  7. K12

    K12 Newbie


    Okay, now after a couple of restarts (I turn off my PC before going to bed). Its now showing as x8 but still not as x16.

    If it helps, I'm using Windows 7 64-bit.

    What I set:
    PEG force x1: OFF
    Set NB Core to 1.40V (as I don't have 1.45V and this is the closest)
    PCI Express Reference (I assumed this was PCI clock) which I set to 100Mhz instead of Auto.
  8. Adrian Wong

    Adrian Wong Da Boss Staff Member

    Did you try changing the PCI Express slot used by your graphics card?
  9. K12

    K12 Newbie

    The manual tells me that the slot its in is the x16 slot. For the P5KR, its the blue slot, and that's the slot I have put it in. Do you think I should try it anyway?
  10. Adrian Wong

    Adrian Wong Da Boss Staff Member

    Sorry, haven't had the time to check the specs of the P5KR. My Internet has been acting up these few days... :wall: :wall:

    Is that the only x16 slot you have? It's actually okay if you get stuck at x8. The performance difference between x16 and x8 is insignificant. You just want to avoid getting stuck at x1.
  11. K12

    K12 Newbie

    That's alright, but I'm wondering as to why its stuck @ 8x. There has to be something wrong right?
  12. Adrian Wong

    Adrian Wong Da Boss Staff Member

    Definitely. But be thankful you can even get it up to x8. Some people are still stuck at x1. Your graphics card's performance at x8 is virtually similar to its performance if x16 was enabled. Can't say the same thing if you are stuck at x1.

    Are you using the latest 0703 BIOS?

    I just loaded the manual. There are two x16 PCI Express slots. Why don't you try switching the card to the other PCI Express x16 slot?

    There aren't many PCI Express-specific BIOS options to play with. However, I noticed there's a PEG Port Control option. You could try DISABLING it.
  13. K12

    K12 Newbie

    The other slot only runs in x4 or x1 modes. Correct me if I'm wrong.
  14. Adrian Wong

    Adrian Wong Da Boss Staff Member

    Ahh.. you are right. The second slot is x16 physically but can only support x4 or x1. :(

    Try disabling PEG Port Control and see if that helps.
  15. Adrian Wong

    Adrian Wong Da Boss Staff Member

    How To Fix The PCI Express x1 Bug Rev. 3.2

    User of ASUS and Gigabyte motherboards (maybe others as well) may be affected by a PCI Express x1 bug which causes a tremendous drop in performance. ChampionLLY takes a look at the motherboards and graphics cards affected by this problem and what solutions work, and what doesn’t.

    In the second part, he takes a look at the effect that PCI Express x1 bug has on the performance of your system. The results will shock you.

    Here are the latest updates in Revision 3.2 :-

    Link : How To Fix The PCI Express x1 Bug Rev. 3.2
  16. palemo44

    palemo44 Newbie

    Hi guys, i have same problem
    my setup:
    MSI P6N SLI V2 BIOS V 1.4
    [email protected]
    GF 9600GT PALIT
    2GB PC 5200
    Amacrox Warrior 450w

    i try cheange vnb, pci-e frequency and no effect, please help me:(((
  17. Adrian Wong

    Adrian Wong Da Boss Staff Member

    Perhaps, you can try posting PCI Express related BIOS settings you are currently using?

    Have you also tried switching PCI Express slots for your graphics card?
  18. palemo44

    palemo44 Newbie

    Yes, i tried switch slots but x1 both, now all in my bios is default options
    i tried:
    pci-e 101,102,103...till 115
    vnb 1.25->1.45 (max)
    vsb 1.50-1.70
    hdd format
    reinstall drivers
    switch psu
    switch sli switcher to x8/x8

    today i tried with Radeon HD4850 but still its x1
    no more ideas:confused:
  19. Adrian Wong

    Adrian Wong Da Boss Staff Member

    Wow.. That's really bad.

    If you can, please list down all the PCI Express BIOS options and their current settings.

    BTW, have you tried downclocking the PCI Express speed?
  20. Machforr

    Machforr Newbie

    While that person MIGHT have confused the PCIe values of x1, x16, 2.0 etc, I can vouch for the fact that the P5KPL-CM has the bug as well. However, I juuuust managed to get rid of it.

    The board has a very very VERY limited bios in terms of parameters that can be changed.

    System config:
    Intel P4 3Ghz
    Asus P5KPL-CM
    2Gb ram
    ATI radeon X1900XTX

    Going into the jumperfree settings, I set the AI overclocking to MANUAL

    In the default value that was 200, I just put 201. I overclocked the system by 1mhz and BAM! Pci Express at x16.

    Considering the already borderline system performance, it is a welcome releif to have taken care of it.

    Hopefully this can help other users.
    1 person likes this.

Share This Page