PC HardFreeze : Plz Help

Discussion in 'BIOS Optimization Guide (BOG)' started by utkal, Sep 2, 2009.

  1. utkal

    utkal Newbie

    Hi Friends

    I have the following h/w configuration. And my PC was working fine till now. Recently I have upgraded my motherboard AMI BIOS to its latest version (1011) and then accepted the default setting of the BIOS. Unfortunately before flashing the BIOS, I had not note down/backed up the different settings, set by the dealer at Nehru Palace, New Delhi.

    1. ASUS K8N motherboard (Socket 754)
    2. AMD Athlon 64 2800+
    3. MSI T128 (nVidia GeForce FX 5200) AGP graphics card
    4. Kingston 512 MB DDR1 RAM
    5. 320 GB Seagate ATA HDD

    Now, after BIOS upgrade with its default settings, my PC is booting up normally. But whenever I'm trying to run any moderate application like IE, Firefox, VLCPlayer, etc ... my PC goes into HARD FREEZE mode/hangs permanently. And then neither the mouse, nor the keyboard works which then needs hard boot by resetting the power button :( Note that, this behaviour is across the OSes like WinXP SP3, Ubuntu 9.04, etc .... hence I thing there is something wrong at root/BIOS level. I have all the latest drivers for my components but still living with this problem.

    Again, when I'm uninstalling the graphics driver, the PC works well without hang but the display is toooooooo slow. So again, I thing there is something wrong in BIOS and graphics card settings combination.

    I have also disabled FASTWRITE/AGP side bus, but still no result.

    Please help me.
  2. Adrian Wong

    Adrian Wong Da Boss Staff Member

    Hi utkal,

    You might want to take photos of the BIOS screens and post them up here so we can see what's set.

    Sounds like an IRQ-related issue. Check and see if ACPI and APIC have been enabled.
  3. utkal

    utkal Newbie

    Thank you friend.
    I'll take the snapshots of my BIOS and share with you. Hope now here I'll get the solution :lol:
  4. Adrian Wong

    Adrian Wong Da Boss Staff Member

    We will be here. :beer:
  5. utkal

    utkal Newbie

    Here are the BIOS settings pics of my with above said problem.
    Plz help me.


    Thank you.
  6. utkal

    utkal Newbie

    Here is the screenshot of HWMonitor app ..
  7. Adrian Wong

    Adrian Wong Da Boss Staff Member

    Here are stuff you should change :

    32Bit Data Transfer -> Enabled
    AI Overclock Tuner -> Auto
    MemClock Mode -> Auto
    Master ECC Enable -> Disabled
    ACPI 2.0 Support -> Enabled

    Let us know how it goes. :beer:
  8. utkal

    utkal Newbie

    I have modified the settings you have proposed along with ...
    AI over Clock Tuner->Standard (as there is no option of Auto there)

    But still the same problem of hardfreeze :(
    You were saying something related to IRQ.
    Are you seeing anything fishy there ?
    If you want I can post other screens too.
  9. zy

    zy zynine.com Staff Member

    2nd screen

    UDMA -> 5

    6th screen

    Allocate IRQ to PCI VGA -> off/disabled
  10. Chai

    Chai Administrator Staff Member

    Change the 1T/2T timing to 2T.
  11. Adrian Wong

    Adrian Wong Da Boss Staff Member

    Eh, IRQ should be allocated to the PCI VGA. :think:

    Yeah, the 1T/2T Timing should be increased to 2T.
  12. Adrian Wong

    Adrian Wong Da Boss Staff Member

    BTW, noticed thate you are using Linux. You should try enabling Plug And Play OS.
  13. utkal

    utkal Newbie

    Friends...I have tried all ur suggested settings, but the problem is there :( Now it started freezing in safemode also.

    I have googled a lot and found that the problem may be for AGP rate. How can I change the default AGP rate of 8X to 4X in Ubuntu 9.04 or WinXP ?

    Thank you.
  14. utkal

    utkal Newbie

    BTW, friends, now I have noticed same IRQ is assigned to multiple PCI devices (see the IRQ11 on the attached image). Could it be the source of the problem ? If yes, plz tell me the solution for it.
    Another thing I forgot to inform you that, I have couple of PCI devices attached to my PC like ...
    1. Skystar2 DVB-S PCI card
    2. Additional NIC PCI card

    Plz help.

    Last edited: Sep 7, 2009
  15. zy

    zy zynine.com Staff Member

    It could be. I think you can reset it in BIOS or something. OR you can try to exchange slots of the PCI devices.
  16. DarKSeeD

    DarKSeeD BOG Translator

    Something is not right with the HDD also. It should be UDMA5 not 2! Also enable 32bit data transfer.
    Plug and Play OS should be ON!
    Try to lower the PCI Latency Timer to 32. See if it makes the difference.
    In XP if your hdd performs slowly delete from IDE/ATAPI Controllers everything and do a restart and after that the drivers should reinstall properly.
    How about the PSU power?
    Last edited: Sep 7, 2009
  17. utkal

    utkal Newbie

    Thank you friend. But if I'll make the HDD DMA to Auto=UDMA-5 Grub gives error 18. Hence knowingly I'm setting it to UDMA-2. I have enabled 32-bit transfer. But these same IRQ to multiple PCI devices is seems fishy to me.

    What is PSU power ? And how can I monitor it ?
    Last edited: Sep 7, 2009
  18. utkal

    utkal Newbie

    I'm fadeoff with this PC and am going to take this PC to clinic, then I'll post the result here. As its getting freezed during OS installation (may be Windows or Ubuntu) itself !!!
  19. zy

    zy zynine.com Staff Member

    maybe its the hard disk :)
  20. Adrian Wong

    Adrian Wong Da Boss Staff Member

    You might want to shift the location of your PCI cards. I would try shifting the NIC card to a different slot so it doesn't share IRQs with the AGP graphics card.

Share This Page