wireless on vista

Discussion in 'Internet & Networking' started by u suck.com, Feb 10, 2009.

  1. u suck.com

    u suck.com ■ ■ ■ ■


    havent been here for a while..i have a toshiba laptop, running on vista.

    Problem is, the wireless fails sometimes, when this happens, the laptop isn't able to detect ANY wireless networks (it just says that Windows is unable to detect any available networks). Refreshing the wireless detection doesnt help either. The only thing that i can do is restart my laptop and the wireless will work again..

    i'm pretty sure it's a problem with vista. when the wireless fails, it takes longer for the 'connect to a network' window to show up when i click it. i have tried disabling IPv6 as some sites say that it is unstable but it didn't help :(

    what else can i do??? help... ;)
  2. Chai

    Chai Administrator Staff Member

    Do you use Hibernate, Stand By functions? If yes, it looks like the network/wireless network drivers doesn't work properly with power saving, that's why it is only resolved after a restart.
  3. u suck.com

    u suck.com ■ ■ ■ ■

    nope..i dont use any of those functions..my laptop is always on. in fact, in the advance power options, i even made sure that wireless is always on.

    besides, under device manager>wireless adapter>power management, i have unchecked the option 'allow computer to turn off this device to save power'
  4. Chai

    Chai Administrator Staff Member

    Tried updating to the latest drivers?
  5. u suck.com

    u suck.com ■ ■ ■ ■

    done that also..i've also disabled the wireless application that came with Toshiba laptops (Config Free)
  6. Adrian Wong

    Adrian Wong Da Boss Staff Member

    I was also thinking of that option. Always causes problems for some WiFi and LAN devices. :think:

    What about forcing it to only use WiFi-G?

    Yeah, and are you already using the latest driver?
  7. u suck.com

    u suck.com ■ ■ ■ ■

    how do u force it to only use wifi-G?
  8. Adrian Wong

    Adrian Wong Da Boss Staff Member

    There's usually an option in the wireless device's property page in Device Manager.
  9. zy

    zy zynine.com Staff Member

    i would suggest a driver update.

    i had this problem before when i just starting using vista on my dell laptop.

    but after updating the drivers & the OS, it stopped happening.
    what drivers are you using? are you using those from toshiba or the manufacturer itself (eg. intel)

    is your vista up to date ?

    what wireless hardware are you running ?
  10. u suck.com

    u suck.com ■ ■ ■ ■

    there's one that says 802.11b preamble and u can choose either 'long or short' or 'long only'

    is that the one?

    and my network adapter shown in device manager is Atheros AR9281 wireless network adapter

    i've also tried disabling 'jump start wireless filter driver' which is recommended by this one site i found but it didnt work either... :(
  11. Adrian Wong

    Adrian Wong Da Boss Staff Member

    Hmm... That's not the one. Sometimes, there's an option like Operating Mode - 802.11b only, 802.11g only, 802.11b/g, etc.

    Have you tried changing to an Atheros driver, instead of the one provided by Toshiba?
  12. u suck.com

    u suck.com ■ ■ ■ ■

    well, the one provided by toshiba IS atheros

    anyway, i tried updating the driver and the problem got worse as in the lack of network detection happened more often than before.

    so i unistalled the driver and i'm back to using the one provided by toshiba.

    right now, my settings:
    1 back to old driver
    2 ipv6 and jumps start filter driver are both disabled
    3 the 802.11b is set as both long and short

    any more ideas? :(
  13. zy

    zy zynine.com Staff Member

  14. Adrian Wong

    Adrian Wong Da Boss Staff Member

    Oh, of course, Toshiba would provide you with an Atheros driver. But OEMs are usually much slower at driver updates than the principal manufacturer. Atheros should have a newer driver than the one provided by Toshiba.
  15. u suck.com

    u suck.com ■ ■ ■ ■

    well, weird thing is with these settings, my wireless hasnt had a problem since. probably the reinstallation of the old driver helped...anyway, hope it stays this way :)
  16. Adrian Wong

    Adrian Wong Da Boss Staff Member

    LOL!! I think it was the reinstallation of the driver. :D

Share This Page